通达信超白金喇叭副图选股指标公式(附源码破译和源码)

发布日期:2024-01-25 05:45    点击次数:201

编程思路破译

ABC1赋值:1日前的收盘价*1.1-收盘价<0.01 AND 最高价=收盘价

ABC2赋值:5

ABC3赋值:3

ABC4赋值:(收盘价的5日指数移动平均*7+收盘价的10日指数移动平均*3)/10

ABC5赋值:如果年份>=2025,返回0,否则返回1

ABC6赋值:最低价的21日指数移动平均+6.8*最低价的2日估算标准差的55日指数移动平均

ABC7赋值:收盘价/ABC6*(1.88*收盘价+最低价+开盘价)/2.75的3日指数移动平均

ABC8赋值:(ABC7-ABC6)/ABC6/2

ABC9赋值:ABC7-ABC8*ABC7的5日指数移动平均*ABC5

ABC10赋值:收盘价的300日指数移动平均-3*收盘价的300日估算标准差

超白金赋值:如果ABC4>ABC9,返回ABC4,否则返回ABC9*ABC5,画洋红色 ,线宽为2

白金赋值:如果ABC9<ABC4ANDABC9<收盘价*0.15,返回收盘价的300日指数移动平均-3*收盘价的300日估算标准差,否则返回ABC9,画洋红色 ,线宽为2

输出喇叭开口:条件连续成立次数=1,画淡红色

程序源码

ABC1:=REF(CLOSE,1)*1.1-CLOSE<0.01 AND HIGH=CLOSE;

ABC2:=5;

ABC3:=3;

ABC4:=(EMA(CLOSE,5)*7+EMA(CLOSE,10)*3)/10;

ABC5:=IF(YEAR>=2025,0,1);

ABC6:=EMA(EMA(LOW,21)+6.8*STD(LOW,2),55);

ABC7:=EMA(CLOSE/ABC6*(1.88*CLOSE+LOW+OPEN)/2.75,3);

ABC8:=(ABC7-ABC6)/ABC6/2;

ABC9:=EMA(ABC7-ABC8*ABC7,5)*ABC5;

ABC10:=EMA(CLOSE,300)-3*STD(CLOSE,300);

超白金:=IF(ABC4>ABC9,ABC4,ABC9)*ABC5,COLORMAGENTA ,LINETHICK2;

白金:=IF(ABC9<ABC4 AND ABC9<CLOSE*0.15,EMA(CLOSE,300)-3*STD(CLOSE,300),ABC9),COLORMAGENTA ,LINETHICK2;

喇叭开口:BARSLASTCOUNT(超白金!=白金)=1,COLORLIRED;

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

       发文不易,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。